summaryrefslogtreecommitdiffstats
path: root/bindings/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevin.rocard@intel.com>2015-02-19 18:18:17 +0100
committerEric Laurent <elaurent@google.com>2015-04-24 13:39:11 -0700
commit46a021d5de6e7448c79f621e0525e920a6206425 (patch)
tree88aab631bf79022ea88cf9a45d8fd1f416d70535 /bindings/CMakeLists.txt
parent9ab48db4862975f81cb19cf3f9db06b26194fc34 (diff)
downloadexternal_parameter-framework-46a021d5de6e7448c79f621e0525e920a6206425.zip
external_parameter-framework-46a021d5de6e7448c79f621e0525e920a6206425.tar.gz
external_parameter-framework-46a021d5de6e7448c79f621e0525e920a6206425.tar.bz2
C pfw bindings
The pfw can not currently be used from c code. Add an c api. It does not target a perfect one/one mapping with the c++ one, but rather aim ease of use and type safety (as far as possible in c). Signed-off-by: Kevin Rocard <kevin.rocard@intel.com>
Diffstat (limited to 'bindings/CMakeLists.txt')
-rw-r--r--bindings/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/bindings/CMakeLists.txt b/bindings/CMakeLists.txt
index ba59221..446b52f 100644
--- a/bindings/CMakeLists.txt
+++ b/bindings/CMakeLists.txt
@@ -30,3 +30,8 @@ option(PYTHON_BINDINGS "Python library to use the pfw from python" ON)
if(PYTHON_BINDINGS)
add_subdirectory(python)
endif()
+
+option(C_BINDINGS "Python library to use the pfw from python" ON)
+if(C_BINDINGS)
+ add_subdirectory(c)
+endif()