summaryrefslogtreecommitdiffstats
path: root/parameter/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wagner <david.wagner@intel.com>2014-02-20 10:35:23 +0100
committerDavid Wagner <david.wagner@intel.com>2014-02-20 10:35:23 +0100
commit3b0dd7b6366ea6e3dc252c347afb58756e007ebb (patch)
treecc0e06027399a6559eb67a2b1fd099ffa11869ff /parameter/CMakeLists.txt
parentd18e82ac2b08e12ae135be38752054856eb90735 (diff)
downloadexternal_parameter-framework-3b0dd7b6366ea6e3dc252c347afb58756e007ebb.zip
external_parameter-framework-3b0dd7b6366ea6e3dc252c347afb58756e007ebb.tar.gz
external_parameter-framework-3b0dd7b6366ea6e3dc252c347afb58756e007ebb.tar.bz2
CMake: export client and plugin headers in separate directories
client headers are exporter in parameter/client; plugin headers in parameter/plugin. Also, reduce the list of exported plugin headers to the bare minimum. Signed-off-by: David Wagner <david.wagner@intel.com>
Diffstat (limited to 'parameter/CMakeLists.txt')
-rw-r--r--parameter/CMakeLists.txt85
1 files changed, 9 insertions, 76 deletions
diff --git a/parameter/CMakeLists.txt b/parameter/CMakeLists.txt
index 1dc1d32..5bef4ec 100644
--- a/parameter/CMakeLists.txt
+++ b/parameter/CMakeLists.txt
@@ -178,103 +178,36 @@ include_directories(
target_link_libraries(parameter xmlserializer pfw_utility)
install(TARGETS parameter LIBRARY DESTINATION lib)
-# TODO: Check if all of these files are truly needed
-# TODO: export client headers and core (plugin) headers separately
+# Client headers
+install(FILES
+ include/ParameterHandle.h
+ include/ParameterMgrPlatformConnector.h
+ include/SelectionCriterionInterface.h
+ include/SelectionCriterionTypeInterface.h
+ DESTINATION "include/parameter/client")
+# Core (plugin) headers
install(FILES
- ## Client headers
- # include/ParameterHandle.h
- # include/ParameterMgrPlatformConnector.h
- # include/SelectionCriterionInterface.h
- # include/SelectionCriterionTypeInterface.h
- ## Core (plugin) headers
- AreaConfiguration.h
- ArrayParameter.h
- AutoLock.h
AutoLog.h
- BackSynchronizer.h
- BaseParameter.h
- BinarySerializableElement.h
- BinaryStream.h
- BitParameter.h
- BitParameterBlock.h
BitParameterBlockType.h
- BitParameterType.h
- BitwiseAreaConfiguration.h
- BooleanParameterType.h
- Component.h
- ComponentInstance.h
- ComponentLibrary.h
- ComponentType.h
- CompoundRule.h
- ConfigurableDomain.h
- ConfigurableDomains.h
ConfigurableElement.h
- ConfigurableElementAggregator.h
- ConfigurationAccessContext.h
DefaultElementLibrary.h
- DomainConfiguration.h
Element.h
ElementBuilder.h
- ElementBuilderTemplate.h
ElementLibrary.h
- ElementLibrarySet.h
- ElementLocator.h
- EnumParameterType.h
- EnumValuePair.h
- ErrorContext.h
- FixedPointParameterType.h
FormattedSubsystemObject.h
- FrameworkConfigurationGroup.h
- FrameworkConfigurationLocation.h
- HardwareBackSynchronizer.h
InstanceConfigurableElement.h
- InstanceDefinition.h
- IntegerParameterType.h
- KindElement.h
- KindElementBuilderTemplate.h
- LinearParameterAdaptation.h
Mapper.h
MappingContext.h
- MappingData.h
NamedElementBuilderTemplate.h
- Parameter.h
- ParameterAccessContext.h
- ParameterAdaptation.h
- ParameterBlackboard.h
- ParameterBlock.h
ParameterBlockType.h
- ParameterFrameworkConfiguration.h
- ParameterMgr.h
- ParameterMgrLogger.h
ParameterType.h
PathNavigator.h
- PluginLocation.h
- Rule.h
- RuleParser.h
- SelectionCriteria.h
- SelectionCriteriaDefinition.h
- SelectionCriterion.h
- SelectionCriterionLibrary.h
- SelectionCriterionRule.h
- SelectionCriterionType.h
- SimulatedBackSynchronizer.h
- StringParameter.h
- StringParameterType.h
Subsystem.h
- SubsystemElementBuilder.h
SubsystemLibrary.h
SubsystemObject.h
SubsystemObjectCreator.h
SubsystemObjectFactory.h
- SubsystemPlugins.h
Syncer.h
- SyncerSet.h
- SystemClass.h
TypeElement.h
VirtualSubsystem.h
- VirtualSyncer.h
- XmlDomainSerializingContext.h
- XmlElementSerializingContext.h
- XmlFileIncluderElement.h
- XmlParameterSerializingContext.h
- DESTINATION "include/parameter")
+ DESTINATION "include/parameter/plugin")