summaryrefslogtreecommitdiffstats
path: root/parameter/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wagner <david.wagner@intel.com>2014-02-18 10:21:16 +0100
committerDavid Wagner <david.wagner@intel.com>2014-02-18 10:21:16 +0100
commit6c91a86d7b07a59f951bbaad5dc799073391a8bb (patch)
treec949d34e8855160a421c6ff657250e7c2547f6fc /parameter/CMakeLists.txt
parent0050049e450ee3a815710c84d724b1575e496800 (diff)
downloadexternal_parameter-framework-6c91a86d7b07a59f951bbaad5dc799073391a8bb.zip
external_parameter-framework-6c91a86d7b07a59f951bbaad5dc799073391a8bb.tar.gz
external_parameter-framework-6c91a86d7b07a59f951bbaad5dc799073391a8bb.tar.bz2
CMake: add rules for installing headers
libparameter abd libxmlserializer headers. Concerning libparameter headers: only core headers (needed for the plugins) are currently exported. We'll need to export the client headers too, but we must make a distiction between the two classes of headers. Also, some currently exported core headers might not be needed (some cleanup is needed). Signed-off-by: David Wagner <david.wagner@intel.com>
Diffstat (limited to 'parameter/CMakeLists.txt')
-rw-r--r--parameter/CMakeLists.txt100
1 files changed, 100 insertions, 0 deletions
diff --git a/parameter/CMakeLists.txt b/parameter/CMakeLists.txt
index 1bbebfb..1dc1d32 100644
--- a/parameter/CMakeLists.txt
+++ b/parameter/CMakeLists.txt
@@ -178,3 +178,103 @@ include_directories(
target_link_libraries(parameter xmlserializer pfw_utility)
install(TARGETS parameter LIBRARY DESTINATION lib)
+# TODO: Check if all of these files are truly needed
+# TODO: export client headers and core (plugin) headers separately
+install(FILES
+ ## Client headers
+ # include/ParameterHandle.h
+ # include/ParameterMgrPlatformConnector.h
+ # include/SelectionCriterionInterface.h
+ # include/SelectionCriterionTypeInterface.h
+ ## Core (plugin) headers
+ AreaConfiguration.h
+ ArrayParameter.h
+ AutoLock.h
+ AutoLog.h
+ BackSynchronizer.h
+ BaseParameter.h
+ BinarySerializableElement.h
+ BinaryStream.h
+ BitParameter.h
+ BitParameterBlock.h
+ BitParameterBlockType.h
+ BitParameterType.h
+ BitwiseAreaConfiguration.h
+ BooleanParameterType.h
+ Component.h
+ ComponentInstance.h
+ ComponentLibrary.h
+ ComponentType.h
+ CompoundRule.h
+ ConfigurableDomain.h
+ ConfigurableDomains.h
+ ConfigurableElement.h
+ ConfigurableElementAggregator.h
+ ConfigurationAccessContext.h
+ DefaultElementLibrary.h
+ DomainConfiguration.h
+ Element.h
+ ElementBuilder.h
+ ElementBuilderTemplate.h
+ ElementLibrary.h
+ ElementLibrarySet.h
+ ElementLocator.h
+ EnumParameterType.h
+ EnumValuePair.h
+ ErrorContext.h
+ FixedPointParameterType.h
+ FormattedSubsystemObject.h
+ FrameworkConfigurationGroup.h
+ FrameworkConfigurationLocation.h
+ HardwareBackSynchronizer.h
+ InstanceConfigurableElement.h
+ InstanceDefinition.h
+ IntegerParameterType.h
+ KindElement.h
+ KindElementBuilderTemplate.h
+ LinearParameterAdaptation.h
+ Mapper.h
+ MappingContext.h
+ MappingData.h
+ NamedElementBuilderTemplate.h
+ Parameter.h
+ ParameterAccessContext.h
+ ParameterAdaptation.h
+ ParameterBlackboard.h
+ ParameterBlock.h
+ ParameterBlockType.h
+ ParameterFrameworkConfiguration.h
+ ParameterMgr.h
+ ParameterMgrLogger.h
+ ParameterType.h
+ PathNavigator.h
+ PluginLocation.h
+ Rule.h
+ RuleParser.h
+ SelectionCriteria.h
+ SelectionCriteriaDefinition.h
+ SelectionCriterion.h
+ SelectionCriterionLibrary.h
+ SelectionCriterionRule.h
+ SelectionCriterionType.h
+ SimulatedBackSynchronizer.h
+ StringParameter.h
+ StringParameterType.h
+ Subsystem.h
+ SubsystemElementBuilder.h
+ SubsystemLibrary.h
+ SubsystemObject.h
+ SubsystemObjectCreator.h
+ SubsystemObjectFactory.h
+ SubsystemPlugins.h
+ Syncer.h
+ SyncerSet.h
+ SystemClass.h
+ TypeElement.h
+ VirtualSubsystem.h
+ VirtualSyncer.h
+ XmlDomainSerializingContext.h
+ XmlElementSerializingContext.h
+ XmlFileIncluderElement.h
+ XmlParameterSerializingContext.h
+ DESTINATION "include/parameter")