summaryrefslogtreecommitdiffstats
path: root/parameter/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Rocard <kevinx.rocard@intel.com>2014-12-05 20:15:35 +0100
committerKevin Rocard <kevinx.rocard@intel.com>2014-12-05 20:19:48 +0100
commit7f7a206ed4f765e80c24fa88ddfea24a4bbb9442 (patch)
treef4cd9223d96dd8b94369eb11d762d714029a68a9 /parameter/CMakeLists.txt
parent7bae0ea65ca57317c0d4da24fe6ad8dab7ffb2f0 (diff)
downloadexternal_parameter-framework-7f7a206ed4f765e80c24fa88ddfea24a4bbb9442.zip
external_parameter-framework-7f7a206ed4f765e80c24fa88ddfea24a4bbb9442.tar.gz
external_parameter-framework-7f7a206ed4f765e80c24fa88ddfea24a4bbb9442.tar.bz2
Link parameter-framework.so with dl
The parameter-framework was using dl{open,close,error} but was not requesting to link with dl. This leaded to compilation failure on non implicit dl distributions. Add explict dependency to dl. Signed-off-by: Kevin Rocard <kevinx.rocard@intel.com>
Diffstat (limited to 'parameter/CMakeLists.txt')
-rw-r--r--parameter/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/parameter/CMakeLists.txt b/parameter/CMakeLists.txt
index f98848f..6836146 100644
--- a/parameter/CMakeLists.txt
+++ b/parameter/CMakeLists.txt
@@ -185,7 +185,8 @@ include_directories(
"${PROJECT_SOURCE_DIR}/remote-processor")
# No need to link with libremote-processor: it is accessed via dlopen()
-target_link_libraries(parameter xmlserializer pfw_utility)
+find_library(dl dl)
+target_link_libraries(parameter xmlserializer pfw_utility dl)
install(TARGETS parameter LIBRARY DESTINATION lib)
# Client headers