summaryrefslogtreecommitdiffstats
path: root/parameter/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Diop <piotrx.diop@intel.com>2015-01-16 17:52:45 +0100
committerPhilippe Afonso <philippex.afonso@intel.com>2015-02-18 11:32:58 +0100
commita1fdb2965956d3cbc62e6f8b29405bdeef79dca3 (patch)
treebc5f64e00c50f4bb68145884c0ee1787d7e10e7d /parameter/CMakeLists.txt
parent96e3a00ec93d76d90aede5538c882caafe23849f (diff)
downloadexternal_parameter-framework-a1fdb2965956d3cbc62e6f8b29405bdeef79dca3.zip
external_parameter-framework-a1fdb2965956d3cbc62e6f8b29405bdeef79dca3.tar.gz
external_parameter-framework-a1fdb2965956d3cbc62e6f8b29405bdeef79dca3.tar.bz2
Create a Logarithm Adaptation parameter type
Some parameters need to be converted to logarithm. This can be the case for volumes that come from HAL as mere decimal values. This patch adds the LogarithmAdaptationParameter type. Change-Id: Ic64232816a82c56a6ddffa5fdccda356eb4ec9c7 Tracked-On: https://jira01.devtools.intel.com/browse/IMINAN-16954 Signed-off-by: Piotr Diop <piotrx.diop@intel.com> Reviewed-on: https://android.intel.com:443/320371
Diffstat (limited to 'parameter/CMakeLists.txt')
-rw-r--r--parameter/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/parameter/CMakeLists.txt b/parameter/CMakeLists.txt
index 9f93da7..94369fb 100644
--- a/parameter/CMakeLists.txt
+++ b/parameter/CMakeLists.txt
@@ -64,6 +64,7 @@ add_library(parameter SHARED
InstanceDefinition.cpp
IntegerParameterType.cpp
LinearParameterAdaptation.cpp
+ LogarithmicParameterAdaptation.cpp
MappingContext.cpp
MappingData.cpp
ParameterAccessContext.cpp