summaryrefslogtreecommitdiffstats
path: root/parameter/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wagner <david.wagner@intel.com>2015-01-06 18:27:08 +0100
committerDavid Wagner <david.wagner@intel.com>2015-01-22 12:02:31 +0100
commitd700782e7dae31cbef37ae038b992d2cb0c6f6a4 (patch)
tree2c67728ffa3830a1fdc4c5ed5798da2b144e85e5 /parameter/CMakeLists.txt
parent70e458c1bb62ad39ea9c59339e74e1f7702910ee (diff)
downloadexternal_parameter-framework-d700782e7dae31cbef37ae038b992d2cb0c6f6a4.zip
external_parameter-framework-d700782e7dae31cbef37ae038b992d2cb0c6f6a4.tar.gz
external_parameter-framework-d700782e7dae31cbef37ae038b992d2cb0c6f6a4.tar.bz2
Make ParameterMgrLogger template
This will make it possible to have different kind of ParameterMgr connectors instead of hardcoding ParameterMgrPlatformConnector in ParameterMgrLogger. Change-Id: Ia78d9f56c8cc73321e1956856755a56a3569b517 Signed-off-by: David Wagner <david.wagner@intel.com>
Diffstat (limited to 'parameter/CMakeLists.txt')
-rw-r--r--parameter/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/parameter/CMakeLists.txt b/parameter/CMakeLists.txt
index 50fc15b..590c7b1 100644
--- a/parameter/CMakeLists.txt
+++ b/parameter/CMakeLists.txt
@@ -79,7 +79,6 @@ add_library(parameter SHARED
BitParameterType.cpp
BitParameter.cpp
ElementLocator.cpp
- ParameterMgrLogger.cpp
AutoLog.cpp
CompoundRule.cpp
SelectionCriterionRule.cpp
@@ -153,7 +152,6 @@ add_library(parameter SHARED
BitParameterType.cpp
BitParameter.cpp
ElementLocator.cpp
- ParameterMgrLogger.cpp
AutoLog.cpp
CompoundRule.cpp
SelectionCriterionRule.cpp
@@ -189,6 +187,7 @@ install(TARGETS parameter LIBRARY DESTINATION lib)
# Client headers
install(FILES
include/ParameterHandle.h
+ include/ParameterMgrLoggerForward.h
include/ParameterMgrPlatformConnector.h
include/SelectionCriterionInterface.h
include/SelectionCriterionTypeInterface.h