summaryrefslogtreecommitdiffstats
path: root/parameter/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wagner <david.wagner@intel.com>2014-02-17 17:55:58 +0100
committerDavid Wagner <david.wagner@intel.com>2014-02-17 17:59:56 +0100
commitf50298799d1d73c0c40940ca5e8cb71a6b28f798 (patch)
tree0e1042c1e50a49dddd3b43ba9afcb370c7c854c9 /parameter/CMakeLists.txt
parent4df5f7eea545fd812f8caad4eefbfa3435516000 (diff)
downloadexternal_parameter-framework-f50298799d1d73c0c40940ca5e8cb71a6b28f798.zip
external_parameter-framework-f50298799d1d73c0c40940ca5e8cb71a6b28f798.tar.gz
external_parameter-framework-f50298799d1d73c0c40940ca5e8cb71a6b28f798.tar.bz2
CMake: clarify why libparameter doesn't link with libremote-processor
It is accessed through dlopen(). Signed-off-by: David Wagner <david.wagner@intel.com>
Diffstat (limited to 'parameter/CMakeLists.txt')
-rw-r--r--parameter/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/parameter/CMakeLists.txt b/parameter/CMakeLists.txt
index 73d6a93..0d962ee 100644
--- a/parameter/CMakeLists.txt
+++ b/parameter/CMakeLists.txt
@@ -173,6 +173,7 @@ include_directories("${PROJECT_SOURCE_DIR}/xmlserializer")
include_directories("${PROJECT_SOURCE_DIR}/utility")
include_directories("${PROJECT_SOURCE_DIR}/remote-processor")
+# No need to link with libremote-processor: it is accessed via dlopen()
target_link_libraries(parameter xmlserializer pfw_utility)
install(TARGETS parameter LIBRARY DESTINATION lib)