summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..283f452
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,19 @@
+# has been tested on 2.8 only - might work on older versions
+cmake_minimum_required(VERSION 2.8)
+
+# linking policy (see cmake --help-policy CMP0003)
+if(COMMAND cmake_policy)
+ cmake_policy(SET CMP0003 NEW)
+endif(COMMAND cmake_policy)
+
+project(parameter-framework)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra") # -Wno-unused-parameter
+
+add_subdirectory(xmlserializer)
+add_subdirectory(parameter)
+add_subdirectory(utility)
+add_subdirectory(remote-processor)
+
+add_subdirectory(remote-process)
+add_subdirectory(test/test-platform)