summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 696e4a0..fcef282 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,10 @@ add_subdirectory(remote-processor)
add_subdirectory(remote-process)
-enable_testing()
+include(CTest)
+# Ctest requires its configuration to be placed at the build root
+configure_file(CTestCustom.cmake ${CMAKE_BINARY_DIR} COPYONLY)
+
add_subdirectory(test/test-platform)
add_subdirectory(test/test-fixed-point-parameter)