aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Maddela <e7appew@gmail.com>2016-03-01 18:47:40 +1100
committerCarlos Maddela <e7appew@gmail.com>2016-10-09 09:08:04 +1100
commit74a9312fb6565d0d3d227b6c959436678ce1dbe2 (patch)
tree5788add7fd143e96a46a188b05631129c936437a
parentc64c42cb1f9487398f8b91a51266ff6e79115b90 (diff)
downloadyoutube-dl-74a9312fb6565d0d3d227b6c959436678ce1dbe2.zip
youtube-dl-74a9312fb6565d0d3d227b6c959436678ce1dbe2.tar.gz
youtube-dl-74a9312fb6565d0d3d227b6c959436678ce1dbe2.tar.bz2
Rebuild with only Python 3 support.
Closes: #723990
-rw-r--r--debian/control10
-rwxr-xr-xdebian/rules8
-rwxr-xr-xdebian/utils/python2
-rwxr-xr-xdebian/utils/pyversions2
4 files changed, 15 insertions, 7 deletions
diff --git a/debian/control b/debian/control
index 51ea9b4..6dcb3b6 100644
--- a/debian/control
+++ b/debian/control
@@ -7,11 +7,11 @@ Build-Depends:
debhelper (>= 9),
dh-python,
pandoc,
- python-pkg-resources,
+ python3-pkg-resources,
zip
Build-Depends-Indep:
- python
-X-Python-Version: >= 2.6
+ python3
+X-Python3-Version: >= 3.2
Standards-Version: 3.9.7
Homepage: https://rg3.github.com/youtube-dl/
Vcs-Git: https://anonscm.debian.org/git/collab-maint/youtube-dl.git
@@ -21,9 +21,9 @@ Package: youtube-dl
Architecture: all
Pre-Depends: dpkg (>= 1.15.7.2)
Depends:
- python-pkg-resources,
+ python3-pkg-resources,
${misc:Depends},
- ${python:Depends}
+ ${python3:Depends},
Recommends:
aria2 | wget | curl,
ca-certificates,
diff --git a/debian/rules b/debian/rules
index 3efd20e..82d26cb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,11 @@
#!/usr/bin/make -f
+
+#export DH_VERBOSE = 1
+export PYBUILD_NAME = youtube_dl
+export PATH := $(CURDIR)/debian/utils:$(PATH)
+
%:
- dh $@ --with python2 --buildsystem=python_distutils \
- --with bash-completion
+ dh $@ --with python3 --buildsystem=pybuild --with bash-completion
override_dh_auto_configure:
PREFIX=/usr SYSCONFDIR=/etc make
diff --git a/debian/utils/python b/debian/utils/python
new file mode 100755
index 0000000..1c65bd1
--- /dev/null
+++ b/debian/utils/python
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/python3 "$@"
diff --git a/debian/utils/pyversions b/debian/utils/pyversions
new file mode 100755
index 0000000..54e34e2
--- /dev/null
+++ b/debian/utils/pyversions
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/py3versions "$@"