summaryrefslogtreecommitdiffstats
path: root/third_party/WebKit/configure.ac
diff options
context:
space:
mode:
authorkeishi@webkit.org <keishi@webkit.org@bbb929c8-8fbe-4397-9dbb-9b2b20218538>2012-03-30 13:15:27 +0000
committerkeishi@webkit.org <keishi@webkit.org@bbb929c8-8fbe-4397-9dbb-9b2b20218538>2012-03-30 13:15:27 +0000
commit10766a9ce6410b24d0e5bb338b88c93c38cb797f (patch)
tree437d95525de4d00b0025430c4e5de78227d1a8e4 /third_party/WebKit/configure.ac
parent0ebdabbf9e4b6b983653b3c5b7e49685aa0ac993 (diff)
downloadchromium_src-10766a9ce6410b24d0e5bb338b88c93c38cb797f.zip
chromium_src-10766a9ce6410b24d0e5bb338b88c93c38cb797f.tar.gz
chromium_src-10766a9ce6410b24d0e5bb338b88c93c38cb797f.tar.bz2
Change ENABLE_INPUT_COLOR to ENABLE_INPUT_TYPE_COLOR and enable it for chromium
https://bugs.webkit.org/show_bug.cgi?id=80972 Reviewed by Kent Tamura. .: * Source/cmake/OptionsBlackBerry.cmake: * configure.ac: Source/JavaScriptCore: * Configurations/FeatureDefines.xcconfig: Source/WebCore: * CMakeLists.txt: * Configurations/FeatureDefines.xcconfig: * GNUmakefile.am: * WebCore.exp.in: * css/html.css: * html/ColorInputType.cpp: * html/ColorInputType.h: * html/HTMLInputElement.cpp: (WebCore): * html/HTMLInputElement.h: (HTMLInputElement): * html/InputType.cpp: (WebCore::createInputTypeFactoryMap): (WebCore): (InputTypeNames): * html/InputType.h: (InputType): (InputTypeNames): * loader/EmptyClients.h: (EmptyChromeClient): * page/Chrome.cpp: (WebCore): * page/Chrome.h: (WebCore): (Chrome): * page/ChromeClient.h: (WebCore): (ChromeClient): * platform/ColorChooser.h: * platform/ColorChooserClient.h: * testing/InternalSettings.cpp: * testing/Internals.cpp: (WebCore): * testing/Internals.h: (Internals): * testing/Internals.idl: Source/WebKit/blackberry: * WebCoreSupport/AboutDataEnableFeatures.in: * WebCoreSupport/ChromeClientBlackBerry.h: (ChromeClientBlackBerry): * WebKitSupport/DOMSupport.cpp: (BlackBerry::WebKit::DOMSupport::isColorInputField): * WebKitSupport/InputHandler.cpp: (BlackBerry::WebKit::convertInputType): Source/WebKit/chromium: * features.gypi: * src/ChromeClientImpl.cpp: (WebKit): * src/ChromeClientImpl.h: (WebCore): (ChromeClientImpl): * src/ColorChooserProxy.cpp: * src/ColorChooserProxy.h: * src/WebColorChooserClientImpl.cpp: * src/WebColorChooserClientImpl.h: Source/WebKit/mac: * Configurations/FeatureDefines.xcconfig: Source/WebKit2: * Configurations/FeatureDefines.xcconfig: Tools: * Scripts/build-webkit: * qmake/mkspecs/features/features.prf: WebKitLibraries: * win/tools/vsprops/FeatureDefines.vsprops: * win/tools/vsprops/FeatureDefinesCairo.vsprops: LayoutTests: * platform/efl/Skipped: * platform/qt/Skipped: git-svn-id: svn://svn.chromium.org/blink/trunk@112658 bbb929c8-8fbe-4397-9dbb-9b2b20218538
Diffstat (limited to 'third_party/WebKit/configure.ac')
-rw-r--r--third_party/WebKit/configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/third_party/WebKit/configure.ac b/third_party/WebKit/configure.ac
index f893124..6ae5d07 100644
--- a/third_party/WebKit/configure.ac
+++ b/third_party/WebKit/configure.ac
@@ -682,11 +682,11 @@ AC_MSG_RESULT([$enable_indexed_database])
# check whether to enable the color input
AC_MSG_CHECKING([whether to enable the color input])
-AC_ARG_ENABLE(input_color,
- AC_HELP_STRING([--enable-input-color],
+AC_ARG_ENABLE(input_type_color,
+ AC_HELP_STRING([--enable-input-type-color],
[enable the color input [default=no]]),
- [],[enable_input_color="no"])
-AC_MSG_RESULT([$enable_input_color])
+ [],[enable_input_type_color="no"])
+AC_MSG_RESULT([$enable_input_type_color])
# check whether to enable the speech input API
AC_MSG_CHECKING([whether to enable the speech input API])
@@ -1352,7 +1352,7 @@ AM_CONDITIONAL([ENABLE_QUOTA],[test "$enable_quota" = "yes"])
AM_CONDITIONAL([ENABLE_ICONDATABASE],[test "$enable_icon_database" = "yes"])
AM_CONDITIONAL([ENABLE_IMAGE_RESIZER],[test "$enable_image_resizer" = "yes"])
AM_CONDITIONAL([ENABLE_INDEXED_DATABASE],[test "$enable_indexed_database" = "yes"])
-AM_CONDITIONAL([ENABLE_INPUT_COLOR],[test "$enable_input_color" = "yes"])
+AM_CONDITIONAL([ENABLE_INPUT_TYPE_COLOR],[test "$enable_input_type_color" = "yes"])
AM_CONDITIONAL([ENABLE_INPUT_SPEECH],[test "$enable_input_speech" = "yes"])
AM_CONDITIONAL([ENABLE_SCRIPTED_SPEECH],[test "$enable_scripted_speech" = "yes"])
AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
@@ -1475,7 +1475,7 @@ Features:
Opcode stats : $enable_opcode_stats
Shadow DOM support : $enable_shadow_dom
SharedWorkers support : $enable_shared_workers
- Color input support : $enable_input_color
+ Color input support : $enable_input_type_color
Speech input support : $enable_input_speech
Scripted speech support : $enable_scripted_speech
SVG support : $enable_svg