summaryrefslogtreecommitdiffstats
path: root/third_party/WebKit/configure.ac
diff options
context:
space:
mode:
authorhans@chromium.org <hans@chromium.org@bbb929c8-8fbe-4397-9dbb-9b2b20218538>2012-03-04 01:06:09 +0000
committerhans@chromium.org <hans@chromium.org@bbb929c8-8fbe-4397-9dbb-9b2b20218538>2012-03-04 01:06:09 +0000
commit22e09f51030e4aa92c7bd52ca7a32d0d7061cf9f (patch)
tree669e253f456c953392a10fb6b052e2a0cd55222b /third_party/WebKit/configure.ac
parentcafd2e5c90a6d6d4232976d398a818e7423102bb (diff)
downloadchromium_src-22e09f51030e4aa92c7bd52ca7a32d0d7061cf9f.zip
chromium_src-22e09f51030e4aa92c7bd52ca7a32d0d7061cf9f.tar.gz
chromium_src-22e09f51030e4aa92c7bd52ca7a32d0d7061cf9f.tar.bz2
Implement Speech JavaScript API
https://bugs.webkit.org/show_bug.cgi?id=80019 Reviewed by Adam Barth. .: Add ENABLE_SCRIPTED_SPEECH. * configure.ac: Source/JavaScriptCore: Add ENABLE_SCRIPTED_SPEECH. * Configurations/FeatureDefines.xcconfig: Source/WebCore: Add ENABLE_SCRIPTED_SPEECH and runtime flag. No functionality yet, so no new tests. * Configurations/FeatureDefines.xcconfig: * GNUmakefile.am: * Target.pri: * bindings/generic/RuntimeEnabledFeatures.cpp: (WebCore): * bindings/generic/RuntimeEnabledFeatures.h: (RuntimeEnabledFeatures): (WebCore::RuntimeEnabledFeatures::setScriptedSpeechEnabled): (WebCore::RuntimeEnabledFeatures::scriptedSpeechEnabled): (WebCore::RuntimeEnabledFeatures::webkitSpeechRecognitionEnabled): (WebCore::RuntimeEnabledFeatures::webkitSpeechRecognitionErrorEnabled): (WebCore::RuntimeEnabledFeatures::webkitSpeechGrammarEnabled): (WebCore::RuntimeEnabledFeatures::webkitSpeechGrammarListEnabled): Source/WebKit/chromium: Add ENABLE_SCRIPTED_SPEECH and runtime flag. * features.gypi: * public/WebRuntimeFeatures.h: (WebRuntimeFeatures): * src/WebRuntimeFeatures.cpp: (WebKit::WebRuntimeFeatures::enableScriptedSpeech): (WebKit): (WebKit::WebRuntimeFeatures::isScriptedSpeechEnabled): Source/WebKit/mac: Add ENABLE_SCRIPTED_SPEECH. * Configurations/FeatureDefines.xcconfig: Source/WebKit2: Add ENABLE_SCRIPTED_SPEECH. * Configurations/FeatureDefines.xcconfig: Tools: Add ENABLE_SCRIPTED_SPEECH. * Scripts/build-webkit: * qmake/mkspecs/features/features.prf: WebKitLibraries: Add ENABLE_SCRIPTED_SPEECH. * win/tools/vsprops/FeatureDefines.vsprops: * win/tools/vsprops/FeatureDefinesCairo.vsprops: git-svn-id: svn://svn.chromium.org/blink/trunk@109667 bbb929c8-8fbe-4397-9dbb-9b2b20218538
Diffstat (limited to 'third_party/WebKit/configure.ac')
-rw-r--r--third_party/WebKit/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/third_party/WebKit/configure.ac b/third_party/WebKit/configure.ac
index 8f8b2e9..054e1d6 100644
--- a/third_party/WebKit/configure.ac
+++ b/third_party/WebKit/configure.ac
@@ -688,6 +688,14 @@ AC_ARG_ENABLE(input_speech,
[],[enable_input_speech="no"])
AC_MSG_RESULT([$enable_input_speech])
+# check whether to enable the scripted speech API
+AC_MSG_CHECKING([whether to enable the scripted speech API])
+AC_ARG_ENABLE(scripted_speech,
+ AC_HELP_STRING([--enable-scripted-speech],
+ [enable the scripted speech API [default=no]]),
+ [],[enable_scripted_speech="no"])
+AC_MSG_RESULT([$enable_scripted_speech])
+
# check whether to build with SQL database support
AC_MSG_CHECKING([whether to enable SQL client-side database storage support])
AC_ARG_ENABLE(sql_database,
@@ -1338,6 +1346,7 @@ AM_CONDITIONAL([ENABLE_IMAGE_RESIZER],[test "$enable_image_resizer" = "yes"])
AM_CONDITIONAL([ENABLE_INDEXED_DATABASE],[test "$enable_indexed_database" = "yes"])
AM_CONDITIONAL([ENABLE_INPUT_COLOR],[test "$enable_input_color" = "yes"])
AM_CONDITIONAL([ENABLE_INPUT_SPEECH],[test "$enable_input_speech" = "yes"])
+AM_CONDITIONAL([ENABLE_SCRIPTED_SPEECH],[test "$enable_scripted_speech" = "yes"])
AM_CONDITIONAL([ENABLE_XSLT],[test "$enable_xslt" = "yes"])
AM_CONDITIONAL([ENABLE_FILTERS],[test "$enable_filters" = "yes"])
AM_CONDITIONAL([ENABLE_GEOLOCATION], [test "$enable_geolocation" = "yes"])
@@ -1459,6 +1468,7 @@ Features:
SharedWorkers support : $enable_shared_workers
Color input support : $enable_input_color
Speech input support : $enable_input_speech
+ Scripted speech support : $enable_scripted_speech
SVG support : $enable_svg
SVG fonts support : $enable_svg_fonts
Web Audio support : $enable_web_audio