summaryrefslogtreecommitdiffstats
path: root/third_party/WebKit/configure.ac
diff options
context:
space:
mode:
authortimothy_horton@apple.com <timothy_horton@apple.com@bbb929c8-8fbe-4397-9dbb-9b2b20218538>2012-05-25 06:53:27 +0000
committertimothy_horton@apple.com <timothy_horton@apple.com@bbb929c8-8fbe-4397-9dbb-9b2b20218538>2012-05-25 06:53:27 +0000
commitb57b105b654fd1fee73860d4757c30e730eab090 (patch)
tree4487f7a161f819299dcc056774b872ebbd8c44a4 /third_party/WebKit/configure.ac
parent64721e1de979249b5160aa5f82f60d71c064c711 (diff)
downloadchromium_src-b57b105b654fd1fee73860d4757c30e730eab090.zip
chromium_src-b57b105b654fd1fee73860d4757c30e730eab090.tar.gz
chromium_src-b57b105b654fd1fee73860d4757c30e730eab090.tar.bz2
Add feature defines for web-facing parts of CSS Regions and Exclusions
https://bugs.webkit.org/show_bug.cgi?id=87442 <rdar://problem/10887709> Reviewed by Dan Bernstein. * configure.ac: * Configurations/FeatureDefines.xcconfig: * Configurations/FeatureDefines.xcconfig: * GNUmakefile.am: * bindings/generic/RuntimeEnabledFeatures.cpp: * bindings/generic/RuntimeEnabledFeatures.h: (RuntimeEnabledFeatures): (WebCore::RuntimeEnabledFeatures::setCSSExclusionsEnabled): (WebCore::RuntimeEnabledFeatures::cssExclusionsEnabled): * bindings/js/JSCSSRuleCustom.cpp: (WebCore::toJS): * bindings/objc/DOMCSS.mm: (kitClass): * css/CSSComputedStyleDeclaration.cpp: (WebCore::CSSComputedStyleDeclaration::getPropertyCSSValue): * css/CSSParser.cpp: (WebCore::isSimpleLengthPropertyID): (WebCore::isValidKeywordPropertyAndValue): (WebCore::isKeywordPropertyID): (WebCore::CSSParser::parseValue): (WebCore::CSSParser::detectAtToken): * css/CSSProperty.cpp: (WebCore::CSSProperty::isInheritedProperty): * css/CSSPropertyNames.in: * css/CSSRule.cpp: (WebCore::CSSRule::cssText): (WebCore::CSSRule::destroy): (WebCore::CSSRule::reattach): * css/CSSRule.h: (WebCore::CSSRule::isRegionRule): * css/CSSRule.idl: * css/StyleBuilder.cpp: (WebCore::StyleBuilder::StyleBuilder): * css/StylePropertySet.cpp: (WebCore::StylePropertySet::getPropertyValue): (WebCore::StylePropertySet::asText): * css/StylePropertyShorthand.cpp: (WebCore::shorthandForProperty): * css/StylePropertyShorthand.h: * css/StyleResolver.cpp: (WebCore::StyleResolver::collectMatchingRulesForList): * css/StyleRule.cpp: (WebCore::StyleRuleBase::destroy): (WebCore::StyleRuleBase::copy): (WebCore::StyleRuleBase::createCSSOMWrapper): * css/WebKitCSSRegionRule.cpp: * css/WebKitCSSRegionRule.h: * css/WebKitCSSRegionRule.idl: * dom/Document.cpp: * dom/Document.h: * dom/Document.idl: * page/DOMWindow.idl: * page/Settings.cpp: (WebCore::Settings::Settings): * page/Settings.h: (WebCore::Settings::setCSSRegionsEnabled): (WebCore::Settings::cssRegionsEnabled): * features.gypi: * Configurations/FeatureDefines.xcconfig: * Configurations/FeatureDefines.xcconfig: * Scripts/webkitperl/FeatureList.pm: git-svn-id: svn://svn.chromium.org/blink/trunk@118484 bbb929c8-8fbe-4397-9dbb-9b2b20218538
Diffstat (limited to 'third_party/WebKit/configure.ac')
-rw-r--r--third_party/WebKit/configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/third_party/WebKit/configure.ac b/third_party/WebKit/configure.ac
index 5caa091..895dfc5 100644
--- a/third_party/WebKit/configure.ac
+++ b/third_party/WebKit/configure.ac
@@ -1100,6 +1100,22 @@ AC_ARG_ENABLE(font_boosting,
[],[enable_font_boosting="no"])
AC_MSG_RESULT([$enable_font_boosting])
+# check whether to enable CSS Exclusions support
+AC_MSG_CHECKING([whether to enable CSS Exclusions])
+AC_ARG_ENABLE(css_exclusions,
+ AC_HELP_STRING([--enable-css-exclusions],
+ [enable support for CSS Exclusions [default=yes]]),
+ [],[enable_css_exclusions="yes"])
+AC_MSG_RESULT([$enable_css_exclusions])
+
+# check whether to enable CSS Regions support
+AC_MSG_CHECKING([whether to enable CSS Regions])
+AC_ARG_ENABLE(css_regions,
+ AC_HELP_STRING([--enable-css-regions],
+ [enable support for CSS Regions [default=yes]]),
+ [],[enable_css_regions="yes"])
+AC_MSG_RESULT([$enable_css_regions])
+
G_IR_SCANNER=
G_IR_COMPILER=
G_IR_GENERATE=
@@ -1425,6 +1441,8 @@ AM_CONDITIONAL([ENABLE_DEVICE_ORIENTATION],[test "$enable_device_orientation" =
AM_CONDITIONAL([ENABLE_MUTATION_OBSERVERS],[test "$enable_mutation_observers" = "yes"])
AM_CONDITIONAL([ENABLE_IFRAME_SEAMLESS],[test "$enable_iframe_seamless" = "yes"])
AM_CONDITIONAL([ENABLE_FONT_BOOSTING],[test "$enable_font_boosting" = "yes"])
+AM_CONDITIONAL([ENABLE_CSS_EXCLUSIONS],[test "$enable_css_exclusions" = "yes"])
+AM_CONDITIONAL([ENABLE_CSS_REGIONS],[test "$enable_css_regions" = "yes"])
# Gtk conditionals
AM_CONDITIONAL([ENABLE_INTROSPECTION],[test "$enable_introspection" = "yes"])
@@ -1476,6 +1494,8 @@ Features:
Blob support : $enable_blob
CSS3 Flexbox support : $enable_css3_flexbox
Legacy WebKitBlobBuilder support : $enable_legacy_webkit_blob_builder
+ CSS Exclusions support : $enable_css_exclusions
+ CSS Regions support : $enable_css_regions
DOM mutation observer support : $enable_mutation_observers
DeviceOrientation support : $enable_device_orientation
Directory upload : $enable_directory_upload