summaryrefslogtreecommitdiffstats
path: root/third_party/tcmalloc/vendor/Makefile.am
diff options
context:
space:
mode:
authorsgk@chromium.org <sgk@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>2009-11-25 22:17:26 +0000
committersgk@chromium.org <sgk@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>2009-11-25 22:17:26 +0000
commit3b1ea24972af975f96f7bdf6040fbc5048ea8b6d (patch)
treef3b855b44c1d61d0c2b0fb734dc8125069b862c2 /third_party/tcmalloc/vendor/Makefile.am
parentaa1aad14bca48ad0b871b80267241b3a791926f8 (diff)
downloadchromium_src-3b1ea24972af975f96f7bdf6040fbc5048ea8b6d.zip
chromium_src-3b1ea24972af975f96f7bdf6040fbc5048ea8b6d.tar.gz
chromium_src-3b1ea24972af975f96f7bdf6040fbc5048ea8b6d.tar.bz2
Match the vendor branch to the current tcmalloc rev in DEPS.
BUG=27911 TEST=none Review URL: http://codereview.chromium.org/443010 git-svn-id: svn://svn.chromium.org/chrome/trunk/src@33136 0039d316-1c4b-4281-b951-d872f2087c98
Diffstat (limited to 'third_party/tcmalloc/vendor/Makefile.am')
-rw-r--r--third_party/tcmalloc/vendor/Makefile.am25
1 files changed, 4 insertions, 21 deletions
diff --git a/third_party/tcmalloc/vendor/Makefile.am b/third_party/tcmalloc/vendor/Makefile.am
index c81d8f3..178501d 100644
--- a/third_party/tcmalloc/vendor/Makefile.am
+++ b/third_party/tcmalloc/vendor/Makefile.am
@@ -37,11 +37,8 @@ else !GCC
NO_EXCEPTIONS =
endif !GCC
-# These are x86-specific, having to do with frame-pointers. In
-# particular, some x86_64 systems do not insert frame pointers by
-# default (all i386 systems that I know of, do. I don't know about
-# non-x86 chips). We need to tell perftools what to do about that.
-if X86_64_AND_NO_FP_BY_DEFAULT
+# These are x86-specific, having to do with frame-pointers
+if X86_64
if ENABLE_FRAME_POINTERS
AM_CXXFLAGS += -fno-omit-frame-pointer
else
@@ -49,7 +46,7 @@ else
# before setting this.
AM_CXXFLAGS += -DNO_FRAME_POINTER
endif !ENABLE_FRAME_POINTERS
-endif X86_64_AND_NO_FP_BY_DEFAULT
+endif X86_64
# For windows systems (at least, mingw), we need to tell all our
# tests to link in libtcmalloc using -u. This is because libtcmalloc
@@ -453,11 +450,9 @@ tcmalloc_minimal_large_unittest_LDADD = $(LIBTCMALLOC_MINIMAL) $(PTHREAD_LIBS)
# This tests it works to LD_PRELOAD libtcmalloc (tests maybe_threads.cc)
# In theory this should work under mingw, but mingw has trouble running
# shell scripts that end in .exe. And it doesn't seem to build shared
-# libraries anyway (so can't be LD_PRELOADed) -- in fact, anybody who
-# chooses not to build shared libraries won't be able to run this test.
+# libraries anyway (so can't be LD_PRELOADed).
# TODO(csilvers): figure out how to nix ".exe" or otherwise work under mingw
if !MINGW
-if !ENABLE_STATIC
TESTS += maybe_threads_unittest.sh$(EXEEXT)
maybe_threads_unittest_sh_SOURCES = src/tests/maybe_threads_unittest.sh
noinst_SCRIPTS += $(maybe_threads_unittest_sh_SOURCES)
@@ -468,7 +463,6 @@ maybe_threads_unittest.sh$(EXEEXT): $(top_srcdir)/$(maybe_threads_unittest_sh_SO
low_level_alloc_unittest
rm -f $@
cp -p $(top_srcdir)/$(maybe_threads_unittest_sh_SOURCES) $@
-endif !ENABLE_STATIC
endif !MINGW
# These all tests components of tcmalloc_minimal
@@ -552,17 +546,6 @@ memalign_unittest_LDFLAGS = $(PTHREAD_CFLAGS) $(TCMALLOC_FLAGS)
memalign_unittest_LDADD = $(LIBTCMALLOC_MINIMAL) $(PTHREAD_LIBS)
endif !MINGW
-TESTS += page_heap_test
-WINDOWS_PROJECTS += vsprojects/page_heap_test/page_heap_test.vcproj
-page_heap_test_SOURCES = src/tests/page_heap_test.cc \
- src/config_for_unittests.h \
- src/base/logging.h \
- src/common.h \
- src/page_heap.h
-page_heap_test_CXXFLAGS = $(PTHREAD_CFLAGS) $(AM_CXXFLAGS)
-page_heap_test_LDFLAGS = $(PTHREAD_CFLAGS) $(TCMALLOC_FLAGS)
-page_heap_test_LDADD = $(LIBTCMALLOC_MINIMAL) $(PTHREAD_LIBS)
-
TESTS += pagemap_unittest
WINDOWS_PROJECTS += vsprojects/pagemap_unittest/pagemap_unittest.vcproj
pagemap_unittest_SOURCES = src/tests/pagemap_unittest.cc \