| Commit message (Expand) | Author | Age | Files | Lines |
* | [components] Make zip a component so that src/chromeos can use it. | phajdan.jr@chromium.org | 2013-04-08 | 1 | -195/+0 |
* | Move FilePath->base::FilePath | brettw@chromium.org | 2013-02-11 | 1 | -23/+25 |
* | Use base namespace for FilePath in chrome/common and content/common. | brettw@chromium.org | 2013-02-07 | 1 | -2/+2 |
* | Change zip::ZipFiles() function to take a file descriptor for the dest zip file. | hshi@chromium.org | 2012-11-21 | 1 | -1/+8 |
* | Move scoped_temp_dir from base to base/files | brettw@chromium.org | 2012-11-16 | 1 | -5/+5 |
* | Add zip::ZipFiles() function which creates a zip file for a specified list of... | hshi@chromium.org | 2012-11-09 | 1 | -2/+35 |
* | Change the type of file_type parameter to int, as the parameter actually take... | haruki@chromium.org | 2012-08-12 | 1 | -3/+2 |
* | zip: Add ZipReader and rework Unzip() using the new class. | satorux@chromium.org | 2011-11-11 | 1 | -1/+4 |
* | Fix subtle flakiness from ZipTest. | satorux@chromium.org | 2011-11-01 | 1 | -4/+10 |
* | Put zip functions into 'zip' namespace. | satorux@chromium.org | 2011-10-26 | 1 | -5/+5 |
* | base: Rename FileEnumerator::FILE_TYPE to FileEnumerator::FileType. | tfarina@chromium.org | 2011-08-15 | 1 | -1/+1 |
* | Move scoped_temp_dir and scoped_native_library back from base/memory to base. | thakis@chromium.org | 2011-05-19 | 1 | -1/+1 |
* | Move some files from base to base/memory. | levin@chromium.org | 2011-03-28 | 1 | -2/+2 |
* | wstring: remove some simple instances of ToWStringHack | evan@chromium.org | 2011-03-02 | 1 | -1/+1 |
* | If we can't read a unicode character, write the standard "unknown" (0xFFFD) c... | cevans@chromium.org | 2010-01-01 | 1 | -25/+17 |
* | Fix a path traversal issue in extension unpacking. Because of the sandbox, th... | aa@chromium.org | 2009-11-19 | 1 | -0/+14 |
* | Filter out hidden files, both when loading extensions and when | aa@chromium.org | 2009-10-28 | 1 | -9/+33 |
* | Fix temp file leak in ZipTest. | thestig@chromium.org | 2009-09-02 | 1 | -12/+8 |
* | Avoid directory traversal attacks when unpacking zips. The sandbox would tend | cevans@chromium.org | 2009-07-23 | 1 | -7/+19 |
* | Include a parent directory link in the file list for file:///somepath | yuzo@chromium.org | 2009-06-09 | 1 | -1/+3 |
* | Broaden valgrind supression for known issue in zlib. This seems ok because th... | aa@chromium.org | 2009-06-01 | 1 | -4/+2 |
* | Disable ZipTest on mac (valgrind memory issue) | rafaelw@chromium.org | 2009-06-01 | 1 | -2/+4 |
* | Re-enable zip unit tests. | aa@chromium.org | 2009-06-01 | 1 | -4/+0 |
* | Disable zip tests while trying to figure out problem. | aa@chromium.org | 2009-06-01 | 1 | -1/+2 |
* | Fix bustage again. | aa@chromium.org | 2009-06-01 | 1 | -1/+1 |
* | Fix bustage. | aa@chromium.org | 2009-06-01 | 1 | -3/+6 |
* | Implements a Zip() utility function. Refactor existing | aa@chromium.org | 2009-06-01 | 1 | -0/+105 |