| Commit message (Expand) | Author | Age | Files | Lines |
* | Clean up around NavigationEntryScreenshotManager a bit. | avi | 2015-07-27 | 1 | -6/+4 |
* | Create FrameNavigationEntries for the initial blank page in subframes. | creis | 2015-07-23 | 1 | -5/+0 |
* | Remove NAVIGATION_TYPE_IN_PAGE. | avi | 2015-07-07 | 1 | -4/+0 |
* | Switch RendererDidNavigateInPage to use unique id. | avi | 2015-07-01 | 1 | -1/+4 |
* | Switch to the new ClassifyNavigation. | avi | 2015-06-24 | 1 | -6/+0 |
* | Use scoped_ptr for NavigationEntries. | avi | 2015-06-23 | 1 | -7/+8 |
* | Support simple back/forward in out-of-process iframes. | creis | 2015-06-20 | 1 | -5/+21 |
* | Revert of Use scoped_ptr for NavigationEntries. (patchset #4 id:60001 of http... | thakis | 2015-06-19 | 1 | -8/+7 |
* | Use scoped_ptr for NavigationEntries. | avi | 2015-06-19 | 1 | -7/+8 |
* | Fix the in-page navigation check to look at the correct entry. | avi | 2015-06-08 | 1 | -5/+4 |
* | Fix the commit type for out-of-process iframes. (Attempt 2) | creis | 2015-05-29 | 1 | -0/+6 |
* | Revert of Fix the commit type for out-of-process iframes. (patchset #11 id:20... | caitkp | 2015-05-28 | 1 | -6/+0 |
* | Fix the commit type for out-of-process iframes. | creis | 2015-05-28 | 1 | -0/+6 |
* | Eliminate redundancy in the parameters to NotifyEntryChanged. | avi | 2015-05-20 | 1 | -1/+1 |
* | Classify navigations without page id in parallel to the existing classifier. | avi | 2015-05-08 | 1 | -0/+9 |
* | Revert of Classify navigations without page id in parallel to the existing cl... | ksakamoto | 2015-05-08 | 1 | -9/+0 |
* | Classify navigations without page id in parallel to the existing classifier. | avi | 2015-05-07 | 1 | -0/+9 |
* | Revert of Classify navigations without page id in parallel to the existing cl... | pdr | 2015-05-05 | 1 | -9/+0 |
* | Classify navigations without page id in parallel to the existing classifier. | avi | 2015-05-04 | 1 | -0/+9 |
* | Revert of Classify navigations without page id in parallel to the existing cl... | vkuzkokov | 2015-04-28 | 1 | -9/+0 |
* | Classify navigations without page id in parallel to the existing classifier. | avi | 2015-04-28 | 1 | -0/+9 |
* | Revert of Classify navigations without page id in parallel to the existing cl... | mohsen | 2015-04-27 | 1 | -9/+0 |
* | Classify navigations without page id in parallel to the existing classifier. | avi | 2015-04-27 | 1 | -0/+9 |
* | Fix incorrect creation of duplicate navigation entries for repeated page load... | avi | 2015-04-07 | 1 | -5/+18 |
* | Avoid unnecessary casts in NavigationControllerImpl. | creis | 2015-02-20 | 1 | -17/+17 |
* | Standardize usage of virtual/override/final in content/browser/ | dcheng | 2014-10-21 | 1 | -60/+55 |
* | Replacing the OVERRIDE with override and FINAL with final in content/browser/... | mohan.reddy | 2014-10-07 | 1 | -47/+47 |
* | Move PageTransition from //content/public/common to //ui/base | Sylvain Defresne | 2014-09-19 | 1 | -1/+1 |
* | Simplify AreURLsInPageNavigation | japhet@chromium.org | 2014-06-23 | 1 | -1/+1 |
* | Trust the renderer's same-document navigation flag if it is a same-origin nav. | japhet@chromium.org | 2014-06-04 | 1 | -7/+3 |
* | Don't leave aborted URLs in the omnibox unless we're on the NTP. | creis@chromium.org | 2014-04-22 | 1 | -0/+4 |
* | Revert 265044 "Don't leave aborted URLs in the omnibox unless we..." | rockot@chromium.org | 2014-04-21 | 1 | -4/+0 |
* | Don't leave aborted URLs in the omnibox unless we're on the NTP. | creis@chromium.org | 2014-04-21 | 1 | -0/+4 |
* | Remove frame ID from DidCommitProvisionalLoad. | creis@chromium.org | 2014-03-03 | 1 | -12/+8 |
* | Detect any callers that delete a pending entry while it is still in use. | creis@chromium.org | 2014-02-28 | 1 | -0/+3 |
* | Move DidCommitProvisionalLoad code from RenderView to RenderFrame. | nasko@chromium.org | 2014-02-12 | 1 | -11/+12 |
* | Revert 249516 "Move DidCommitProvisionalLoad code from RenderVie..." | piman@chromium.org | 2014-02-07 | 1 | -12/+11 |
* | Move DidCommitProvisionalLoad code from RenderView to RenderFrame. | nasko@chromium.org | 2014-02-06 | 1 | -11/+12 |
* | Support cross-process navigations in a single subframe RenderFrameHost. | creis@chromium.org | 2013-12-27 | 1 | -3/+17 |
* | Handle should_replace_current_entry in prerender. | davidben@chromium.org | 2013-12-13 | 1 | -2/+2 |
* | Renamed CanPruneAllButVisible and PruneAllButVisible in the Navigation Contro... | jww@chromium.org | 2013-11-13 | 1 | -6/+7 |
* | Remove dead NavigationControllerImpl::IsRedirect. | creis@chromium.org | 2013-11-06 | 1 | -3/+0 |
* | Rename WebContentsScreenshotManager to NavigationEntryScreenshotManager. | nasko@chromium.org | 2013-11-05 | 1 | -3/+3 |
* | Move navigation and frame tree classes to a new frame_host/ directory. | nasko@chromium.org | 2013-10-30 | 1 | -0/+410 |