| Commit message (Expand) | Author | Age | Files | Lines |
* | views: Rename child_widget() to GetChildWidget(). | tfarina@chromium.org | 2011-05-21 | 2 | -4/+6 |
* | Move RootView to the internal namespace. | ben@chromium.org | 2011-05-20 | 2 | -11/+8 |
* | ui/base/models: Convert GetKeyCode() to unit_hacker() style (key_code()). | tfarina@chromium.org | 2011-05-20 | 1 | -1/+1 |
* | Rename WidgetWin/Gtk -> NativeWidgetWin/Gtk. | ben@chromium.org | 2011-05-19 | 2 | -3/+2 |
* | Re-land: | ben@chromium.org | 2011-05-13 | 4 | -11/+11 |
* | Revert 85269 - Split the hierarchy. | ben@chromium.org | 2011-05-13 | 4 | -11/+11 |
* | Split the hierarchy. | ben@chromium.org | 2011-05-13 | 4 | -11/+11 |
* | Step 5 in native theme refactoring | rogerta@chromium.org | 2011-04-27 | 1 | -4/+5 |
* | Rename CreateParams to InitParams. | ben@chromium.org | 2011-04-26 | 2 | -2/+2 |
* | Rework the way Widget::Init works: | ben@chromium.org | 2011-04-26 | 2 | -5/+6 |
* | Centralizes checking for non-null return from CreateWindow. | sky@chromium.org | 2011-04-19 | 1 | -0/+2 |
* | In preparation for NativeTheme refactoring, renaming the class NativeTheme | rogerta@chromium.org | 2011-03-30 | 1 | -3/+3 |
* | Convert more WidgetWin/WidgetGtk creations to use a new cross-platform static... | ben@chromium.org | 2011-03-28 | 3 | -12/+11 |
* | views: Cleanup TabbedPane class. | tfarina@chromium.org | 2011-03-18 | 6 | -98/+119 |
* | Re-land: Refactor Views accessibility. | dmazzoni@chromium.org | 2011-03-14 | 2 | -14/+28 |
* | Build out NativeWindow interface for Window method pass-thrus. | ben@chromium.org | 2011-03-10 | 1 | -1/+1 |
* | Change other usages of .size() to .empty() when applicable. | erg@google.com | 2011-03-04 | 1 | -1/+1 |
* | Revert 76825 - Refactor Views accessibility. | jcivelli@chromium.org | 2011-03-04 | 2 | -28/+14 |
* | Refactor Views accessibility. | dmazzoni@chromium.org | 2011-03-03 | 2 | -14/+28 |
* | Get rid of most of the old method uses from WidgetGtk. I think this is safe. | ben@chromium.org | 2011-03-03 | 1 | -2/+4 |
* | Reverting to fix builder redness. Please fix and reland. | ananta@chromium.org | 2011-03-02 | 1 | -4/+2 |
* | Remove/replace RootView/Widget getters with new NativeWidget getters. | ben@chromium.org | 2011-03-02 | 1 | -2/+4 |
* | These files were meant to go with my change here http://codereview.chromium.o... | ben@chromium.org | 2011-02-24 | 1 | -1/+1 |
* | Move some more direct uses of RootView to Widget. | ben@chromium.org | 2011-02-24 | 1 | -1/+2 |
* | Rename WillGain/Lose/DidGainFocus, Focus methods. Now there are only two noti... | ben@chromium.org | 2011-02-24 | 4 | -6/+6 |
* | Rename Paint* -> OnPaint* | ben@chromium.org | 2011-02-16 | 2 | -3/+3 |
* | Revert 74693. Changing approach. | ben@chromium.org | 2011-02-14 | 2 | -4/+4 |
* | Rename Widgetwin->NativeWidgetWin | ben@chromium.org | 2011-02-11 | 2 | -4/+4 |
* | Rework tree APIs to reflect Google style and more const-correctness.Also, mov... | ben@chromium.org | 2011-02-09 | 2 | -7/+7 |
* | It turns out I had the sense of the GetLocalBounds bool wrong everywhere, so ... | ben@chromium.org | 2011-02-09 | 1 | -2/+2 |
* | Rework basic bounds methods on View to match new V2 API: | ben@chromium.org | 2011-02-08 | 1 | -3/+3 |
* | Change includes of gfx/* to ui/gfx/* | sail@chromium.org | 2011-02-05 | 2 | -6/+6 |
* | views: Move fill_layout.[cc,h] into layout directory. | tfarina@chromium.org | 2011-01-25 | 2 | -4/+4 |
* | Move l10n_util to ui/base | ben@chromium.org | 2011-01-21 | 1 | -1/+1 |
* | Move ResourceBundle, DataPack to ui/base | ben@chromium.org | 2011-01-20 | 1 | -1/+1 |
* | Remove wstring from views. Part 3: Switch accessibility strings to string16. | avi@chromium.org | 2011-01-14 | 1 | -1/+3 |
* | Move app/key* to ui/base/keycodes/* | ben@chromium.org | 2011-01-13 | 1 | -4/+4 |
* | Make accessible getters return values instead of accepting an output paramete... | ctguil@chromium.org | 2010-09-28 | 2 | -6/+3 |
* | Re-lands 58186: | bryeung@chromium.org | 2010-09-03 | 1 | -4/+4 |
* | Revert 58388 - Revert 58215 - Revert 58186 - Move the keyboard files from bas... | akalin@chromium.org | 2010-09-02 | 1 | -4/+4 |
* | Revert 58215 - Revert 58186 - Move the keyboard files from base/ to app/. | bryeung@chromium.org | 2010-09-02 | 1 | -4/+4 |
* | Revert 58186 - Move the keyboard files from base/ to app/. | phajdan.jr@chromium.org | 2010-09-01 | 1 | -4/+4 |
* | Move the keyboard files from base/ to app/. | bryeung@chromium.org | 2010-09-01 | 1 | -4/+4 |
* | Add in a browser test for dialog resizing, which was catching an issue with t... | scottbyer@chromium.org | 2010-08-20 | 1 | -0/+5 |
* | Rework gfx::Font by moving platform-specific code into inner classes. | ben@chromium.org | 2010-08-13 | 1 | -1/+1 |
* | Cleanup: Remove unneeded headers from app/ (part 2) | thestig@chromium.org | 2010-07-31 | 1 | -1/+0 |
* | Fix code path in TabbedPane::RemoveTabAtIndex() | mnissler@chromium.org | 2010-07-27 | 1 | -1/+2 |
* | `#pragma once` for app, base, chrome, gfx, ipc, net, skia, views | thakis@chromium.org | 2010-07-26 | 4 | -0/+4 |
* | Relayout content pref page properly upon sync status changes. | mnissler@chromium.org | 2010-07-15 | 1 | -0/+3 |
* | Fixes focus placement after using ctrl+tab in dialogs. | dtseng@chromium.org | 2010-07-14 | 1 | -7/+7 |