| Commit message (Expand) | Author | Age | Files | Lines |
* | Rename fileapi::LocalFileSystemOperation to FileSystemOperationImpl. | hidehiko@chromium.org | 2013-08-01 | 1 | -541/+0 |
* | Add on_close_callback to AsyncFileUtil::CreateOrOpenCallback. | hidehiko@chromium.org | 2013-07-10 | 1 | -8/+3 |
* | fileapi: Rename FileSystemMountProvider to FileSystemBackend | satorux@chromium.org | 2013-07-09 | 1 | -1/+1 |
* | Fix per-file read permission handling for files in FileSystem API | kinuko@chromium.org | 2013-07-08 | 1 | -1/+0 |
* | Remove unused |created| param from AsyncFileUtil::CreateOrOpenCallback. | hidehiko@chromium.org | 2013-07-02 | 1 | -2/+1 |
* | Add DeleteRecursively to AsyncFileUtil. | hidehiko@chromium.org | 2013-07-01 | 1 | -4/+32 |
* | Use a direct include of time headers in webkit/, win8/. | avi@chromium.org | 2013-06-28 | 1 | -1/+1 |
* | Let LocalFileSystemOperation::SyncGetPlatformPath failed if context returns N... | hidehiko@chromium.org | 2013-06-27 | 1 | -2/+4 |
* | fileapi: Remove platform_path parameter from FileSystemOperation::GetMetadata... | satorux@chromium.org | 2013-06-14 | 1 | -4/+2 |
* | Make FileSystemOperation::Write take closure-friendly parameters | kinuko@chromium.org | 2013-06-13 | 1 | -42/+9 |
* | Make FileSystemOperation NOT self-destruct | kinuko@chromium.org | 2013-06-10 | 1 | -150/+79 |
* | Deprecate LocalFileSystemOperation::SetUp | kinuko@chromium.org | 2013-06-10 | 1 | -226/+3 |
* | Use a direct include of utf_string_conversions.h in google_apis/, gpu/, ipc/,... | avi@chromium.org | 2013-06-07 | 1 | -1/+1 |
* | Add LocalFileSystemOperation support in FileSystemOperationRunner | kinuko@chromium.org | 2013-06-05 | 1 | -49/+27 |
* | Deprecate LocalFileSystemOperation::CreateNestedOperation | kinuko@chromium.org | 2013-06-05 | 1 | -19/+8 |
* | Rename CrossOperationDelegate to CopyOrMoveOperationDelegate | kinuko@chromium.org | 2013-06-04 | 1 | -5/+5 |
* | Update webkit/ to use WeakPtr<T>::get() instead of implicit "operator T*" | akalin@chromium.org | 2013-06-04 | 1 | -1/+1 |
* | Move webkit/quota files to webkit/browser/quota or webkit/common/quota | tzik@chromium.org | 2013-05-30 | 1 | -2/+2 |
* | Move webkit/blob to new locations. Also move content::WebBlobRegistryImpl to ... | michaeln@google.com | 2013-05-29 | 1 | -1/+1 |
* | Split FileAPI code for common|common_child|renderer | kinuko@chromium.org | 2013-05-28 | 1 | -2/+2 |
* | Move browser-specific FileAPI code from webkit/fileapi to webkit/browser/fileapi | kinuko@chromium.org | 2013-05-28 | 1 | -6/+6 |
* | Fix dependency: make file_system_util not depend on FileSystemURL | kinuko@chromium.org | 2013-05-27 | 1 | -2/+2 |
* | Move more browser-specific webkit/fileapi code to webkit/browser/fileapi | kinuko@chromium.org | 2013-05-24 | 1 | -0/+880 |