aboutsummaryrefslogtreecommitdiffstats
path: root/docs/man/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2013-09-04 12:32:46 +0200
committerAleksander Morgado <aleksander@lanedo.com>2013-09-04 12:32:46 +0200
commitf0699a35b00d0ae35198485ce09af83665c4a88a (patch)
tree06e7bfa1bbea91505cc1eade5b5e47dd01bd3cd5 /docs/man/Makefile.am
parent61380bd7ea3421118228d1823e7a3d87d91bda0e (diff)
downloadexternal_libqmi-f0699a35b00d0ae35198485ce09af83665c4a88a.zip
external_libqmi-f0699a35b00d0ae35198485ce09af83665c4a88a.tar.gz
external_libqmi-f0699a35b00d0ae35198485ce09af83665c4a88a.tar.bz2
man: generate qmicli manpage from --help-all
Diffstat (limited to 'docs/man/Makefile.am')
-rw-r--r--docs/man/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/docs/man/Makefile.am b/docs/man/Makefile.am
new file mode 100644
index 0000000..608545b
--- /dev/null
+++ b/docs/man/Makefile.am
@@ -0,0 +1,21 @@
+
+dist_man_MANS = qmicli.1
+
+# List of all source files which affect the output of --help-all
+SOURCES_WITH_HELP = \
+ $(top_srcdir)/cli/qmicli.c \
+ $(top_srcdir)/cli/qmicli-dms.c \
+ $(top_srcdir)/cli/qmicli-nas.c \
+ $(top_srcdir)/cli/qmicli-wds.c \
+ $(top_srcdir)/cli/qmicli-pbm.c \
+ $(top_srcdir)/cli/qmicli-uim.c
+
+# Depend only in the source files, not in the actual program, so that the
+# manpage doesn't get rebuilt when building from a tarball
+qmicli.1: $(SOURCES_WITH_HELP)
+ - $(AM_V_GEN) $(HELP2MAN) \
+ --output=$@ \
+ --name='Control QMI devices' \
+ --help-option='--help-all' \
+ --libtool \
+ $(top_builddir)/cli/qmicli