aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2012-04-26 12:57:23 +0200
committerAleksander Morgado <aleksander@lanedo.com>2012-07-03 16:08:49 +0200
commit08c76d411ce356d22dcaf0622d4c77b385c71385 (patch)
treef5a882ce1fce4d26f5c519a0f61789e3aca6355b /src/Makefile.am
parentc689b969e1964c48ba0893c04f54ad3d882f9c04 (diff)
downloadexternal_libqmi-08c76d411ce356d22dcaf0622d4c77b385c71385.zip
external_libqmi-08c76d411ce356d22dcaf0622d4c77b385c71385.tar.gz
external_libqmi-08c76d411ce356d22dcaf0622d4c77b385c71385.tar.bz2
core: let the `QmiDevice' control the creation and handling of `QmiClient' objects
Instead of treating the QmiClient objects as being independent to the device, we'll make them instead owned by the QmiDevice. This means that the QmiDevice is reponsible for allocationg and releasing the CIDs, and that a QmiClient doesn't need to keep a reference to the QmiDevice around. This simplification allows us to treat the `QmiClientCtl' as completely internal to the library. Uses of the library shouldn't need to interface directly with this object.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 3a99a6d..aec5d77 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -38,7 +38,7 @@ qmi-enum-types.c: $(ENUMS) qmi-enum-types.h $(top_srcdir)/build-aux/qmi-enum-typ
$(ENUMS) > $@
# Additional dependencies
-qmi-device.c: qmi-error-types.h
+qmi-device.c: qmi-error-types.h qmi-enum-types.h
qmi-client.c: qmi-error-types.h qmi-enum-types.h
qmi-client-ctl.c: qmi-error-types.h qmi-enum-types.h
qmi-message.c: qmi-error-types.h qmi-enum-types.h
@@ -68,5 +68,4 @@ include_HEADERS = \
qmi-enums.h qmi-enum-types.h \
qmi-device.h \
qmi-client.h \
- qmi-ctl.h qmi-client-ctl.h \
qmi-dms.h qmi-client-dms.h