aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2012-04-20 13:34:16 +0200
committerAleksander Morgado <aleksander@lanedo.com>2012-07-03 15:47:21 +0200
commit6d8225abd2494e348cac2115c695417e2903c5fe (patch)
treedee46c19382d7673287561ef47bad104827f4c44 /src/Makefile.am
parent02467a15bdca99c6cd80cac62414ca725fd3a277 (diff)
downloadexternal_libqmi-6d8225abd2494e348cac2115c695417e2903c5fe.zip
external_libqmi-6d8225abd2494e348cac2115c695417e2903c5fe.tar.gz
external_libqmi-6d8225abd2494e348cac2115c695417e2903c5fe.tar.bz2
client-ctl: new `QmiClientCtl' to handle the CTL service
The `QmiDevice' will create one of these objects and keep it around, to be used as the generic client in the CTL service.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b7326c5..d1be081 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -39,6 +39,7 @@ qmi-enum-types.c: qmi-enums.h qmi-enum-types.h $(top_srcdir)/build-aux/qmi-enum-
# Additional dependencies
qmi-device.c: qmi-error-types.h
qmi-client.c: qmi-error-types.h qmi-enum-types.h
+qmi-client-ctl.c: qmi-error-types.h
qmi-message.c: qmi-error-types.h
qmi-message-ctl.c: qmi-error-types.h
@@ -50,7 +51,8 @@ libqmi_glib_la_SOURCES = \
qmi-message.h qmi-message.c \
qmi-message-ctl.h qmi-message-ctl.c \
qmi-device.h qmi-device.c \
- qmi-client.h qmi-client.c
+ qmi-client.h qmi-client.c \
+ qmi-client-ctl.h qmi-client-ctl.c
libqmi_glib_la_LIBADD = \
$(LIBQMI_GLIB_LIBS)
@@ -61,4 +63,5 @@ include_HEADERS = \
qmi-errors.h qmi-error-types.h \
qmi-enums.h qmi-enum-types.h \
qmi-device.h \
- qmi-client.h
+ qmi-client.h \
+ qmi-client-ctl.h