aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2012-05-19 11:46:52 +0200
committerAleksander Morgado <aleksander@lanedo.com>2012-07-03 16:08:53 +0200
commitb97d32fd322b8c6c543ede58813556d0b01f31c8 (patch)
tree90acd23ac9c6c0b767f800b32d9845f2dac549c0 /src/Makefile.am
parentac2a3802fa25d5f4832b1e2595534f7379c6c924 (diff)
downloadexternal_libqmi-b97d32fd322b8c6c543ede58813556d0b01f31c8.zip
external_libqmi-b97d32fd322b8c6c543ede58813556d0b01f31c8.tar.gz
external_libqmi-b97d32fd322b8c6c543ede58813556d0b01f31c8.tar.bz2
qmi-codegen: pass input and output files with command line options
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2fa6ba3..e3d4ae7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -40,8 +40,8 @@ qmi-enum-types.c: $(ENUMS) qmi-enum-types.h $(top_srcdir)/build-aux/templates/qm
# CTL service
qmi-ctl.stamp: $(top_srcdir)/data/qmi-service-ctl.json $(top_srcdir)/build-aux/qmi-codegen/*.py $(top_srcdir)/build-aux/qmi-codegen/qmi-codegen
$(AM_V_GEN) $(top_srcdir)/build-aux/qmi-codegen/qmi-codegen \
- $(top_srcdir)/data/qmi-service-ctl.json \
- qmi-ctl && \
+ --input $(top_srcdir)/data/qmi-service-ctl.json \
+ --output qmi-ctl && \
touch $@
# Additional dependencies