aboutsummaryrefslogtreecommitdiffstats
path: root/docs/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/man/Makefile.am')
-rw-r--r--docs/man/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/docs/man/Makefile.am b/docs/man/Makefile.am
index 030b5b8..983dda9 100644
--- a/docs/man/Makefile.am
+++ b/docs/man/Makefile.am
@@ -1,7 +1,9 @@
dist_man_MANS = \
- qmicli.1 \
- qmi-network.1
+ qmicli.1 \
+ qmi-network.1 \
+ qmi-firmware-update.1 \
+ $(NULL)
# List of all source files which affect the output of --help-all
QMICLI_SOURCES_WITH_HELP = \
@@ -37,3 +39,16 @@ qmi-network.1: $(top_srcdir)/utils/qmi-network.in
--name='Simple network management of QMI devices' \
$(top_builddir)/utils/qmi-network || \
touch $@
+
+# Depend only in the source files, not in the actual program, so that the
+# manpage doesn't get rebuilt when building from a tarball
+# Also, make sure that the qmi-firmware-update.1 file is always generated, even
+# when help2man is not available
+qmi-firmware-update.1: $(top_srcdir)/src/qmi-firmware-update/qfu-main.c
+ $(AM_V_GEN) \
+ $(HELP2MAN) \
+ --output=$@ \
+ --name='Update firmware in QMI devices' \
+ --libtool \
+ $(top_builddir)/src/qmi-firmware-update/qmi-firmware-update || \
+ touch $@