aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorWolfgang Wiedmeyer <wolfgit@wiedmeyer.de>2016-12-03 21:14:43 +0100
committerWolfgang Wiedmeyer <wolfgit@wiedmeyer.de>2016-12-03 21:14:43 +0100
commitc4ef220497dd42c682ab25e18ee22e7c41e1a460 (patch)
tree7798c804b32876098adb1551f372525361cdf23b /debian/patches
parent0b9ee148f5234d4e9fef6110e512dd7e95a5641b (diff)
downloadyoutube-dl-c4ef220497dd42c682ab25e18ee22e7c41e1a460.zip
youtube-dl-c4ef220497dd42c682ab25e18ee22e7c41e1a460.tar.gz
youtube-dl-c4ef220497dd42c682ab25e18ee22e7c41e1a460.tar.bz2
merge debian folder of latest unstable release
Signed-off-by: Wolfgang Wiedmeyer <wolfgit@wiedmeyer.de>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix_libav_compat_outdated.patch41
-rw-r--r--debian/patches/series2
-rw-r--r--debian/patches/skip_support_file_installation.patch34
3 files changed, 77 insertions, 0 deletions
diff --git a/debian/patches/fix_libav_compat_outdated.patch b/debian/patches/fix_libav_compat_outdated.patch
new file mode 100644
index 0000000..f86a0b0
--- /dev/null
+++ b/debian/patches/fix_libav_compat_outdated.patch
@@ -0,0 +1,41 @@
+From: Carlos Maddela <e7appew@gmail.com>
+Date: Wed, 2 Mar 2016 04:20:06 +1100
+Subject: Stop libav compatibility links from being considered as genuine.
+
+Description: Stop libav compatibility links from being considered as genuine.
+ Don't register version numbers for compatibility links, so that
+ youtube-dl stops complaining about avconv being outdated.
+Author: Carlos Maddela <e7appew@gmail.com>
+Origin: vendor
+Bug: https://github.com/rg3/youtube-dl/pull/8720
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=798936
+Last-Update: 2016-06-27
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+---
+ youtube_dl/postprocessor/ffmpeg.py | 9 +++++++--
+ 1 file changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/youtube_dl/postprocessor/ffmpeg.py b/youtube_dl/postprocessor/ffmpeg.py
+index fa99b0c..29beb48 100644
+--- a/youtube_dl/postprocessor/ffmpeg.py
++++ b/youtube_dl/postprocessor/ffmpeg.py
+@@ -98,11 +98,16 @@ class FFmpegPostProcessor(PostProcessor):
+ self._paths = dict(
+ (p, os.path.join(location, p)) for p in programs)
+ self._versions = dict(
+- (p, get_exe_version(self._paths[p], args=['-version']))
++ (p, get_exe_version(self._paths[p], args=['-version'],
++ version_re=r'%s\s+version\s+([-0-9._a-zA-Z]+)' % p,
++ unrecognized=False))
+ for p in programs)
+ if self._versions is None:
+ self._versions = dict(
+- (p, get_exe_version(p, args=['-version'])) for p in programs)
++ (p, get_exe_version(p, args=['-version'],
++ version_re=r'%s\s+version\s+([-0-9._a-zA-Z]+)' % p,
++ unrecognized=False))
++ for p in programs)
+ self._paths = dict((p, p) for p in programs)
+
+ if prefer_ffmpeg:
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..21895fb
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+skip_support_file_installation.patch
+fix_libav_compat_outdated.patch
diff --git a/debian/patches/skip_support_file_installation.patch b/debian/patches/skip_support_file_installation.patch
new file mode 100644
index 0000000..1e5506f
--- /dev/null
+++ b/debian/patches/skip_support_file_installation.patch
@@ -0,0 +1,34 @@
+From: Carlos Maddela <e7appew@gmail.com>
+Date: Tue, 1 Mar 2016 02:31:47 +1100
+Subject: Don't install support files via setup.py
+
+Description: Don't install support files via setup.py
+ for better control over where they should be installed.
+Author: Carlos Maddela <e7appew@gmail.com>
+Origin: vendor
+Forwarded: not-needed
+Last-Update: 2016-06-27
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+---
+ setup.py | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 508b27f..7b13ef7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -58,12 +58,7 @@ py2exe_params = {
+ if len(sys.argv) >= 2 and sys.argv[1] == 'py2exe':
+ params = py2exe_params
+ else:
+- files_spec = [
+- ('etc/bash_completion.d', ['youtube-dl.bash-completion']),
+- ('etc/fish/completions', ['youtube-dl.fish']),
+- ('share/doc/youtube_dl', ['README.txt']),
+- ('share/man/man1', ['youtube-dl.1'])
+- ]
++ files_spec = []
+ root = os.path.dirname(os.path.abspath(__file__))
+ data_files = []
+ for dirname, files in files_spec: