aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPhilipp Hagemeister <phihag@phihag.de>2014-01-27 06:22:15 +0100
committerPhilipp Hagemeister <phihag@phihag.de>2014-01-27 06:22:15 +0100
commit6c57e8a063b7e34208ac9e225786e8152943303a (patch)
treef6d32f5e8ece43548843d549aaa838941b77e5e9 /setup.py
parentdb1f388878db8ce2ae6473a5447a5aa6c9ea86f1 (diff)
downloadyoutube-dl-6c57e8a063b7e34208ac9e225786e8152943303a.zip
youtube-dl-6c57e8a063b7e34208ac9e225786e8152943303a.tar.gz
youtube-dl-6c57e8a063b7e34208ac9e225786e8152943303a.tar.bz2
[setup.py] Only print a warning if documentation files are missing (Fixes #780)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 19 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 1f45159..03e7b35 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,9 @@
from __future__ import print_function
+import os.path
import pkg_resources
+import warnings
import sys
try:
@@ -44,12 +46,24 @@ py2exe_params = {
if len(sys.argv) >= 2 and sys.argv[1] == 'py2exe':
params = py2exe_params
else:
+ files_spec = [
+ ('etc/bash_completion.d', ['youtube-dl.bash-completion']),
+ ('share/doc/youtube_dl', ['README.txt']),
+ ('share/man/man1', ['youtube-dl.1'])
+ ]
+ root = os.path.dirname(os.path.abspath(__file__))
+ data_files = []
+ for dirname, files in files_spec:
+ resfiles = []
+ for fn in files:
+ if not os.path.exists(fn):
+ warnings.warn('Skipping file %s since it is not present. Type make to build all automatically generated files.' % fn)
+ else:
+ resfiles.append(fn)
+ data_files.append((dirname, resfiles))
+
params = {
- 'data_files': [ # Installing system-wide would require sudo...
- ('etc/bash_completion.d', ['youtube-dl.bash-completion']),
- ('share/doc/youtube_dl', ['README.txt']),
- ('share/man/man1', ['youtube-dl.1'])
- ]
+ 'data_files': data_files,
}
if setuptools_available:
params['entry_points'] = {'console_scripts': ['youtube-dl = youtube_dl:main']}