aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorgcmalloc <gcmalloc@gmail.com>2012-11-28 18:49:56 +0100
committergcmalloc <gcmalloc@gmail.com>2012-11-28 18:49:56 +0100
commit87bec4c7155d390c3f6e716c87616ce8cdf1450a (patch)
treee6afee2832eaf7a01fddf946b93a6103047c4c92 /setup.py
parent190e8e27d8446aaf6cdb992cf1255267bed48d74 (diff)
downloadyoutube-dl-87bec4c7155d390c3f6e716c87616ce8cdf1450a.zip
youtube-dl-87bec4c7155d390c3f6e716c87616ce8cdf1450a.tar.gz
youtube-dl-87bec4c7155d390c3f6e716c87616ce8cdf1450a.tar.bz2
getting version from git or failing
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py20
1 files changed, 13 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 3eccf50..d90856b 100644
--- a/setup.py
+++ b/setup.py
@@ -5,15 +5,22 @@ try:
except ImportError:
sys.stderr.write("Cannot import py2exe")
import os
+import subprocess
-"""This will create an exe that needs Microsoft Visual C++ 2008 Redistributable Package"""
+"""The p2exe option will create an exe that needs Microsoft Visual C++ 2008 Redistributable Package.
+ python setup.py py2exe
+ You can also build a zip executable with
+ python setup.py bdist --format=zip
+
+
+"""
# If run without args, build executables
if len(sys.argv) == 1:
sys.argv.append("py2exe")
# os.chdir(os.path.dirname(os.path.abspath(sys.argv[0]))) # conflict with wine-py2exe.sh
-sys.path.append('./youtube_dl')
+#sys.path.append('./youtube_dl')
options = {
"bundle_files": 1,
@@ -29,11 +36,10 @@ console = [{
}]
init_file = open('./youtube_dl/__init__.py')
-for line in init_file.readlines():
- if line.startswith('__version__'):
- version = line[11:].strip(" ='\n")
- break
-else:
+
+try:
+ version = subprocess.checkoutput(["git", "describe", "--abbrev=0", "--tags"])
+except:
version = ''
setup(name='youtube-dl',