aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPhilipp Hagemeister <phihag@phihag.de>2013-06-24 00:01:41 +0200
committerPhilipp Hagemeister <phihag@phihag.de>2013-06-24 00:01:41 +0200
commite646ffe795460592bbb39af455fc9f159bd7e5ae (patch)
tree9f24bfb7fcad61804f2a7f433ca73afaf3021277 /setup.py
parentb07d9c23c57007c7af17c5b949d3a648a8492b8c (diff)
downloadyoutube-dl-e646ffe795460592bbb39af455fc9f159bd7e5ae.zip
youtube-dl-e646ffe795460592bbb39af455fc9f159bd7e5ae.tar.gz
youtube-dl-e646ffe795460592bbb39af455fc9f159bd7e5ae.tar.bz2
Add included files for Windows build
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index eb7b1a2..c59ab08 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,8 @@
# -*- coding: utf-8 -*-
from __future__ import print_function
+
+from glob import glob
import pkg_resources
import sys
@@ -23,7 +25,9 @@ py2exe_options = {
"compressed": 1,
"optimize": 2,
"dist_dir": '.',
- "dll_excludes": ['w9xpopen.exe']
+ "dll_excludes": ['w9xpopen.exe'],
+ "includes": [m.replace('\\', '.').replace('/', '.')[:-3]
+ for m in glob('youtube_dl/*/*.py')]
}
py2exe_console = [{
"script": "./youtube_dl/__main__.py",